Re: [PATCH 05/22] sequencer: allow the sequencer to take custody of malloc()ed data
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Aug 30, 2016, 07:30 UTC
- Message-ID
- <alpine.DEB.2.20.1608300929420.129229@virtualbox>
- In-Reply-To
- <e0a00df7-d4e7-3809-ae93-b29b1f1c7ea4@kdbg.org>
Hi Hannes,
On Tue, 30 Aug 2016, Johannes Sixt wrote:
Show 17 quoted lines
> Am 29.08.2016 um 23:59 schrieb Jakub Narębski:
> > W dniu 29.08.2016 o 10:04, Johannes Schindelin pisze:
> > > -#define REPLAY_OPTS_INIT { -1, -1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, NULL,
> > > NULL, NULL, 0, 0, NULL }
> > > +#define REPLAY_OPTS_INIT { -1, -1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, NULL,
> > > NULL, NULL, 0, 0, NULL, NULL, 0, 0 }
> >
> > Nb. it is a pity that we cannot use named initializers for structs,
> > so called designated inits. It would make this macro more readable.
>
> It is actually pointless to add the 0's and NULL's here. This should be
> sufficient:
>
> #define REPLAY_OPTS_INIT { -1, -1 }
>
> because initialization with 0 (or NULL) is the default for any omitted
> members.D'oh. You're right. The same applies to TODO_LIST_INIT, of course.
Fixed, Johannes