Re: [PATCH 02/10] trailer: include "trailer" term in API functions
- From
- Linus Arver <linusa@google.com>
- Date
- Jan 19, 2024, 00:12 UTC
- Message-ID
- <owlyv87qgozb.fsf@fine.c.googlers.com>
- In-Reply-To
- <xmqqfryup98u.fsf@gitster.g>
Junio C Hamano <gitster@pobox.com> writes:
Show 14 quoted lines
> "Linus Arver via GitGitGadget" <gitgitgadget@gmail.com> writes: > >> From: Linus Arver <linusa@google.com> >> >> These functions are exposed to clients and so they should include >> "trailer" in their names for easier identification, just like all the >> other functions already exposed by trailer.h. > > Oh, if you were to do this and code movement in two separate > patches, doing the rename before the move in the previous step would > have made much more sense. If we stopped after 01/10, the tree > would have been a very sorry state. If this came first, even if we > stop after these renaming of internal functions that are not extern, > nobody wil be hurt by these new and improved names.
Ah very true. I think I was thinking of the series as one atomic thing (all 10 patches or nothing), which is a bad habit I need to break. I'll reorder these two on the next reroll, because principles matter (and it's an easy mechanical change). Thanks.