From: Linus Arver Date: Fri, 19 Jan 2024 00:12:56 GMT Subject: Re: [PATCH 02/10] trailer: include "trailer" term in API functions Message-ID: In-Reply-To: Junio C Hamano writes: > "Linus Arver via GitGitGadget" writes: > >> From: Linus Arver >> >> These functions are exposed to clients and so they should include >> "trailer" in their names for easier identification, just like all the >> other functions already exposed by trailer.h. > > Oh, if you were to do this and code movement in two separate > patches, doing the rename before the move in the previous step would > have made much more sense. If we stopped after 01/10, the tree > would have been a very sorry state. If this came first, even if we > stop after these renaming of internal functions that are not extern, > nobody wil be hurt by these new and improved names. Ah very true. I think I was thinking of the series as one atomic thing (all 10 patches or nothing), which is a bad habit I need to break. I'll reorder these two on the next reroll, because principles matter (and it's an easy mechanical change). Thanks.