Re: [PATCH v4 22/28] trailer: prepare to delete "parse_trailers_from_command_line_args()"
- From
Christian Couder <christian.couder@gmail.com>
- Date
- Feb 12, 2024, 23:39 UTC
- Message-ID
- <CAP8UFD3pcyRYaJLBmiDdN3sdvRzo==dx-CQKoX1w1n6Hsg5+-g@mail.gmail.com>
- In-Reply-To
- <94bf182e3ffbf8ed6e20cd77b2e46e5b83c44d34.1707196348.git.gitgitgadget@gmail.com>
On Tue, Feb 6, 2024 at 6:12 AM Linus Arver via GitGitGadget <gitgitgadget@gmail.com> wrote:
Show 19 quoted lines
> > From: Linus Arver <linusa@google.com> > > Expose more functions in the trailer.h API, in preparation for deleting > > parse_trailers_from_command_line_args() > > from the trailers implementation, because it should not be concerned > with command line arguments (as they have nothing to do with trailers > themselves). Indeed, the interpret-trailers builtin is the only caller > of this function inside Git. > > Rename add_arg_item() to trailer_add_arg_item() to expose it as an API > function. Rename new_trailers_clear() to free_new_trailers() because it > will be promoted into an API function; the API already has > free_trailers(), so using the "free_*" naming style will keep it > consistent. Also rename "conf_info" to "trailer_conf" for readability, > dropping the low-value "_info" suffix as we did earlier in this series > for "trailer_info" to "trailer_block".
That's a lot done in a single patch. I think splitting it into 3 or more patches would be nice for reviewers.