Re: [PATCH 07/10] trailer: spread usage of "trailer_block" language
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Jan 19, 2024, 01:03 UTC
- Message-ID
- <xmqqttnam8wd.fsf@gitster.g>
- In-Reply-To
- <9183990583f9a591c79301a20fa327462bb50cf9.1704869487.git.gitgitgadget@gmail.com>
"Linus Arver via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 7 quoted lines
> From: Linus Arver <linusa@google.com> > > Deprecate the "trailer_info" struct name and replace it with > "trailer_block". The main reason is to help readability, because > "trailer_info" on the surface sounds like it's about a single trailer > when in reality it is a collection of contiguous lines, at least 25% of > which are trailers.
Together with the introduction of trailer_block_{start,end}() accessor functions in the previous step, this sounds like the right thing to do.
"info" is a word with so low information contents. At least "block" would hint that we are talking about a block of text that makes up the trailer attached to a single commit.