Re: [PATCH v2 05/13] reftable: utility functions
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Oct 15, 2020, 11:46 UTC
- Message-ID
- <nycvar.QRO.7.76.6.2010151346060.56@tvgsbejvaqbjf.bet>
- In-Reply-To
- <xmqqo8l6ku0y.fsf@gitster.c.googlers.com>
Hi Junio,
On Tue, 13 Oct 2020, Junio C Hamano wrote:
Show 10 quoted lines
> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes: > > > Somewhat related: I was wondering whether it would make sense for git.git > > to rename `strbuf` to `git_buf`? Would that make it easier to exchange > > code between the two projects? Or would it just be unnecessary churn? > > To us, "git_buf" is just as descriptive as "buf" and does not say > anything about the nature of 'buf' (other than apparently it was > invented and widely used here). "git_strbuf" I can understand, but > why should we?
If it makes code sharing between git.git and libgit2 easier, why shouldn't we ;-)
Obviously, if it doesn't make life easier, we shouldn't bother.
Ciao, Dscho