Re: [PATCH v2 05/13] reftable: utility functions
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Oct 15, 2020, 16:23 UTC
- Message-ID
- <xmqqwnzrh30f.fsf@gitster.c.googlers.com>
- In-Reply-To
- <nycvar.QRO.7.76.6.2010151346060.56@tvgsbejvaqbjf.bet>
Johannes Schindelin <Johannes.Schindelin@gmx.de> writes:
Show 17 quoted lines
> Hi Junio, > > On Tue, 13 Oct 2020, Junio C Hamano wrote: > >> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes: >> >> > Somewhat related: I was wondering whether it would make sense for git.git >> > to rename `strbuf` to `git_buf`? Would that make it easier to exchange >> > code between the two projects? Or would it just be unnecessary churn? >> >> To us, "git_buf" is just as descriptive as "buf" and does not say >> anything about the nature of 'buf' (other than apparently it was >> invented and widely used here). "git_strbuf" I can understand, but >> why should we? > > If it makes code sharing between git.git and libgit2 easier, why shouldn't > we ;-)
I see no reasonably explanation why libgit2 is not the one who uses "#define strbuf git_buf" to make "sharing easier", though.