From: Johannes Schindelin Date: Thu, 15 Oct 2020 11:46:50 GMT Subject: Re: [PATCH v2 05/13] reftable: utility functions Message-ID: In-Reply-To: Hi Junio, On Tue, 13 Oct 2020, Junio C Hamano wrote: > Johannes Schindelin writes: > > > Somewhat related: I was wondering whether it would make sense for git.git > > to rename `strbuf` to `git_buf`? Would that make it easier to exchange > > code between the two projects? Or would it just be unnecessary churn? > > To us, "git_buf" is just as descriptive as "buf" and does not say > anything about the nature of 'buf' (other than apparently it was > invented and widely used here). "git_strbuf" I can understand, but > why should we? If it makes code sharing between git.git and libgit2 easier, why shouldn't we ;-) Obviously, if it doesn't make life easier, we shouldn't bother. Ciao, Dscho