Re: [PATCH v2 05/13] reftable: utility functions
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Oct 15, 2020, 19:39 UTC
- Message-ID
- <nycvar.QRO.7.76.6.2010152139390.56@tvgsbejvaqbjf.bet>
- In-Reply-To
- <xmqqwnzrh30f.fsf@gitster.c.googlers.com>
Hi Junio,
On Thu, 15 Oct 2020, Junio C Hamano wrote:
Show 22 quoted lines
> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes: > > > Hi Junio, > > > > On Tue, 13 Oct 2020, Junio C Hamano wrote: > > > >> Johannes Schindelin <Johannes.Schindelin@gmx.de> writes: > >> > >> > Somewhat related: I was wondering whether it would make sense for git.git > >> > to rename `strbuf` to `git_buf`? Would that make it easier to exchange > >> > code between the two projects? Or would it just be unnecessary churn? > >> > >> To us, "git_buf" is just as descriptive as "buf" and does not say > >> anything about the nature of 'buf' (other than apparently it was > >> invented and widely used here). "git_strbuf" I can understand, but > >> why should we? > > > > If it makes code sharing between git.git and libgit2 easier, why shouldn't > > we ;-) > > I see no reasonably explanation why libgit2 is not the one who uses > "#define strbuf git_buf" to make "sharing easier", though.
That's a fair point, thanks for bringing it up!
Ciao, Dscho