Re: [PATCH v8 2/3] bisect: rewrite `check_term_format` shell function in C
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- May 25, 2016, 05:04 UTC
- Message-ID
- <alpine.DEB.2.20.1605250657250.4449@virtualbox>
- In-Reply-To
- <20160524072124.2945-3-pranit.bauva@gmail.com>
Hi Pranit,
I think this patch series is now in a fine shape. Just one minor nit:
On Tue, 24 May 2016, Pranit Bauva wrote:
> + OPT_CMDMODE(0, "check-term-format", &cmdmode,
> + N_("check format of the term"), CHECK_TERM_FMT),Just like with cmd_mode and CMD_MODE, it would be more consistent to use CHECK_TERM_FORMAT (instead of abbreviating it) when the option is already spelled --check-term-format and the function name is check_term_format.
It not only causes the eyes to stumble less, being consistent in naming causes less typos and also makes it easier to dig into the source code (think: `git grep -i check.name.format`).
Not a big thing, but if you re-roll for any other reason, it would be good to make the naming consistent, too.
Ciao, Johannes