Re: [PATCH 1/2] bisect--helper: use OPT_CMDMODE instead of OPT_BOOL
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- May 4, 2016, 06:07 UTC
- Message-ID
- <CAPig+cQxpZXKqykFoa2kzCZSC2YqpPXnGocs2YttcJ+rCxmzgQ@mail.gmail.com>
- In-Reply-To
- <1462338472-3581-2-git-send-email-pranit.bauva@gmail.com>
On Wed, May 4, 2016 at 1:07 AM, Pranit Bauva <pranit.bauva@gmail.com> wrote:
> bisect--helper: use OPT_CMDMODE instead of OPT_BOOL
This subject is too low-level, talking about implementation details, whereas it should be giving a high-level summary of the change.
> `--next-all` is meant to be used as a sub command to support multiple > "operation mode" though the current implementation does not contain any > other sub command along side with `--next-all` but further commits will > include some more subcommands.
You've spelled this as both "sub command" and "subcommand". Choose one and stick with it. ("subcommand" is probably more common.)
Show 8 quoted lines
> Signed-off-by: Pranit Bauva <pranit.bauva@gmail.com>
> ---
> diff --git a/builtin/bisect--helper.c b/builtin/bisect--helper.c
> @@ -8,13 +8,17 @@ static const char * const git_bisect_helper_usage[] = {
> NULL
> };
>
> +enum sub_commands {How about calling this 'enum subcommand' (no underscore, non-plural)?
Show 7 quoted lines
> + NEXT_ALL = 1
> +};
> +
> int cmd_bisect__helper(int argc, const char **argv, const char *prefix)
> {
> - int next_all = 0;
> + int sub_command = 0;s/sub_command/subcommand/
Show 20 quoted lines
> struct option options[] = {
> - OPT_BOOL(0, "next-all", &next_all,
> - N_("perform 'git bisect next'")),
> + OPT_CMDMODE(0, "next-all", &sub_command,
> + N_("perform 'git bisect next'"), NEXT_ALL),
> @@ -23,9 +27,14 @@ int cmd_bisect__helper(int argc, const char **argv, const char *prefix)
> argc = parse_options(argc, argv, prefix, options,
> git_bisect_helper_usage, 0);
>
> - if (!next_all)
> + if (!sub_command)
> usage_with_options(git_bisect_helper_usage, options);
>
> - /* next-all */
> - return bisect_next_all(prefix, no_checkout);
> + switch (sub_command) {
> + case NEXT_ALL:
> + return bisect_next_all(prefix, no_checkout);
> + default:
> + die(_("bug: unknown subcommand '%d'"), sub_command);s/bug/BUG/
Also, as this is a programmer error rather than an end-user error, it does not need to be localized, thus drop the _(...).
> + } > + return 0; > }