Re: [PATCH v10 3/8] refs.c: refactor to reuse ref_is_hidden()
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Apr 12, 2020, 21:38 UTC
- Message-ID
- <xmqq1rose65v.fsf@gitster.c.googlers.com>
- In-Reply-To
- <20200412133022.17590-4-worldhello.net@gmail.com>
Jiang Xin <worldhello.net@gmail.com> writes:
> From: Jiang Xin <zhiyou.jx@alibaba-inc.com> > > Add new function `ref_is_matched()` to reuse `ref_is_hidden()`. Will use
ref_is_matched() may not be wrong per-se, but I would imagine that ref_matches() would sound more natural.
The ancient varilabe hide_refs is probably misnamed and should be renamed when the codebase is quiescent to hidden_refs but of course we shouldn't do so before stablizing this series.