Re: [PATCH v10 3/8] refs.c: refactor to reuse ref_is_hidden()
Junio C Hamano <gitster@pobox.com> 于2020年4月13日周一 上午5:38写道:
Show 9 quoted lines
>
> Jiang Xin <worldhello.net@gmail.com> writes:
>
> > From: Jiang Xin <zhiyou.jx@alibaba-inc.com>
> >
> > Add new function `ref_is_matched()` to reuse `ref_is_hidden()`. Will use
>
> ref_is_matched() may not be wrong per-se, but I would imagine that
> ref_matches() would sound more natural.
Show 5 quoted lines
>
> The ancient varilabe hide_refs is probably misnamed and should be
> renamed when the codebase is quiescent to hidden_refs but of course
> we shouldn't do so before stablizing this series.
>