Changes since v1:
* Use a better name "proc-receive" for the new hook.
* Rename the new config variable to "receive.procReceiveRefs".
--
Jiang Xin (5):
receive-pack: add new proc-receive hook
refs.c: refactor to reuse ref_is_hidden()
receive-pack: new config receive.procReceiveRefs
receive-pack: read env from proc-receive output
hook: add document and example for "proc-receive" hook
Documentation/config/receive.txt | 14 +
Documentation/githooks.txt | 22 +
builtin/receive-pack.c | 160 +++++-
refs.c | 11 +-
refs.h | 1 +
t/t5411-proc-receive-hook.sh | 831 +++++++++++++++++++++++++++
templates/hooks--proc-receive.sample | 119 ++++
7 files changed, 1141 insertions(+), 17 deletions(-)
create mode 100755 t/t5411-proc-receive-hook.sh
create mode 100755 templates/hooks--proc-receive.sample