From: Junio C Hamano Date: Sun, 12 Apr 2020 21:38:20 GMT Subject: Re: [PATCH v10 3/8] refs.c: refactor to reuse ref_is_hidden() Message-ID: In-Reply-To: <20200412133022.17590-4-worldhello.net@gmail.com> Jiang Xin writes: > From: Jiang Xin > > Add new function `ref_is_matched()` to reuse `ref_is_hidden()`. Will use ref_is_matched() may not be wrong per-se, but I would imagine that ref_matches() would sound more natural. The ancient varilabe hide_refs is probably misnamed and should be renamed when the codebase is quiescent to hidden_refs but of course we shouldn't do so before stablizing this series.