Re: [PATCH v3 02/17] object-store: rename `object_directory` to `odb_alternate`
- From
Patrick Steinhardt <ps@pks.im>
- Date
- May 30, 2025, 09:39 UTC
- Message-ID
- <aDl8tnjQsqXEy8l-@pks.im>
- In-Reply-To
- <euflgbipchqi7jvmz4yzwzx6ao5guen6xmupkdaubjbc5ksgkp@aheynye35bby>
On Tue, May 27, 2025 at 11:45:14AM -0500, Justin Tobler wrote:
Show 7 quoted lines
> On 25/05/26 07:45AM, Patrick Steinhardt wrote: > > Furthermore, we already do have the distinction between > > "local" and "non-local" objects, which translates quite well into this > > new naming schema. > > Just to clarify, are you referring to how we differentiate between local > and alternate odbs? I'm not quite sure I fully understand.
Yeah. Non-local objects come from an alternate object directory, whereas local objects come from the primary object directory.
Patrick