Re: [PATCH 01/17] object-store: rename `raw_object_store` to `object_database`
- From
Junio C Hamano <gitster@pobox.com>
- Date
- May 7, 2025, 15:27 UTC
- Message-ID
- <xmqqv7qce915.fsf@gitster.g>
- In-Reply-To
- <3317228e-e1c8-4b69-9f03-f344f5a6a0cb@gmail.com>
Derrick Stolee <stolee@gmail.com> writes:
Show 10 quoted lines
> On 5/6/25 7:09 AM, Patrick Steinhardt wrote: > >> Instead, rename the structure to `object_database`. This term is already >> used a lot throughout our codebase, and it cannot easily be mistaken for >> "object directories", either. Furthermore, its acronym ODB is already >> well-known and works well as part of a function's name, like for example >> `odb_has_object()`. > > The patch is the kind where "it's correct if and only if it compiles," > which is good!
Yes, unless there are topics in flight that adds more uses independently; I think there weren't any, though, which is good.