Re: [PATCH 00/17] object-store: carve out the object database subsystem
On Tue, May 13, 2025 at 09:28:30PM +0200, Toon Claes wrote:
Show 14 quoted lines
> Patrick Steinhardt <ps@pks.im> writes:
>
> > ... I have decided to rename this to `odb_alternate`. I don't think
> > "shard" works well, as shard is an extremely generic term that doesn't
> > really convey much meaning.
> >
> > On the other hand, I think that `odb_alternate` is quite a good fit. We
> > already use it all over the place to mean almost exactly what we are
> > after here. And it doesn't seem far-fetched to have an
> > `odb_packed_alternate`, `odb_loose_alternate` and `odb_redis_alternate`
> > for different backends.
>
> So a database is a collection of alternates? And the alternates are
> stored as a linked list?
Show 6 quoted lines
> > The only stretch is that the primary object directory is now the primary
> > alternate. I think that this is acceptable though'
>
> This is a very important nuance, and with that knowledge it starts to
> click with me. I didn't read this in the commit messages though, so I
> think it's worth adding something about that in [PATCH 02/17].
Good point, done now.
Patrick