Re: [PATCH 01/17] object-store: rename `raw_object_store` to `object_database`
- From
Derrick Stolee <stolee@gmail.com>
- Date
- May 7, 2025, 00:47 UTC
- Message-ID
- <3317228e-e1c8-4b69-9f03-f344f5a6a0cb@gmail.com>
- In-Reply-To
- <20250506-pks-object-store-wo-the-repository-v1-1-c05b82e7b126@pks.im>
On 5/6/25 7:09 AM, Patrick Steinhardt wrote:
Show 5 quoted lines
> Instead, rename the structure to `object_database`. This term is already > used a lot throughout our codebase, and it cannot easily be mistaken for > "object directories", either. Furthermore, its acronym ODB is already > well-known and works well as part of a function's name, like for example > `odb_has_object()`.
The patch is the kind where "it's correct if and only if it compiles," which is good!
I just wanted to chime in to approve of the term "object database" and using ODB for short.
Thanks, -Stolee