Re: [PATCH v5 17/17] odb: rename `read_object_with_reference()`
On 25/06/05 08:47AM, Patrick Steinhardt wrote:
Show 10 quoted lines
> Rename `read_object_with_reference()` to `odb_read_object_peeled()` to
> match other functions related to the object database and our modern
> coding guidelines. Furthermore though, the old name didn't really
> describe very well what this function actually does, which is to walk
> down any commit and tag objects until an object of the required type has
> been found. This is generally referred to as "peeling", so the new name
> should be way more descriptive.
>
> No compatibility wrapper is introduces as the function is not used a lot
> throughout our codebase.
Same small typo:
s/introduces/introduced/
The change itself looks good though :)
-Justin