Re: [PATCH v8 36/37] run-command: stop thinking about hooks
- From
Emily Shaffer <emilyshaffer@google.com>
- Date
- Mar 30, 2021, 00:07 UTC
- Message-ID
- <YGJrpnCVMnM1KNjM@google.com>
- In-Reply-To
- <87v99wg1xw.fsf@evledraar.gmail.com>
On Fri, Mar 12, 2021 at 10:23:55AM +0100, Ævar Arnfjörð Bjarmason wrote:
Show 14 quoted lines
> > > On Thu, Mar 11 2021, Emily Shaffer wrote: > > > hook.h has replaced all run-command.h hook-related functionality. > > run-command.h:run_hooks_le/ve and find_hook are no longer used anywhere > > in the codebase. So, let's delete the dead code - or, in the one case > > where it's still needed, move it to an internal function in hook.c. > > Similar to other comments about squashing, I think just having this > happen incrementally as we remove whatever is the last user of the > function would be better. > > E.g. find_hook() is last used in one commit, run_hook*() in another...
Hm. I could see it, coupled with a blurb like, "Nobody is using this anymore so delete."
But it feels odd to move the find_hook() impl from here to hook.c internal in a commit about, say, bugreport.
I'll consider this, thanks. Maybe it fits in one case (like run_hook_*) better than in another (like find_hook). I'll play with it :)
- Emily