Re: [PATCH 4/4] tests: remove most uses of test_i18ncmp
- From
Jonathan Nieder <jrnieder@gmail.com>
- Date
- Feb 19, 2021, 21:25 UTC
- Message-ID
- <YDAsvpIzgsIhh+5X@google.com>
- In-Reply-To
- <xmqqa6say0h8.fsf@gitster.c.googlers.com>
Junio C Hamano wrote:
> Ævar Arnfjörð Bjarmason <avarab@gmail.com> writes:
Show 8 quoted lines
>> As a follow-up to d162b25f956 (tests: remove support for >> GIT_TEST_GETTEXT_POISON, 2021-01-20) remove most uses of test_i18ncmp >> via a simple s/test_i18ncmp/test_cmp/g search-replacement. > > I am a bit hesitant to take this step, primarily because the > distinction between test_cmp and test_i18ncmp is serving as a sign > for tests to identify if they are dealing with translatable messages > or plumbing/machine-readable messages.
I agree: in particular, I would value the ability to run tests with, say, LANG=fr_CH.UTF-8 and catch localization-specific issues that way. Removing the test_i18ncmp helper removes that ability.
That said:
[...]
> So, perhaps we should bite the bullet and just take this step.
If we don't have a convenient way to keep "testing the testsuite" (i.e., some kind of CI run that uses a locale other than C), then I agree that explicitly removing the test_i18ncmp / test_cmp distinction is better than letting it bitrot.
Thanks, Jonathan