Re: [PATCH 1/2] Add strbuf_initf()
- From
Mike Hommey <mh@glandium.org>
- Date
- Mar 6, 2008, 06:33 UTC
- Message-ID
- <20080306063331.GA7325@glandium.org>
- In-Reply-To
- <alpine.LSU.1.00.0803060212170.15786@racer.site>
On Thu, Mar 06, 2008 at 02:14:43AM +0100, Johannes Schindelin wrote:
Show 9 quoted lines
> > The most common use of addf() was to init a strbuf and addf() right away. > Since it is so common, it makes sense to have a function strbuf_initf() > to wrap both calls into one. > > Unfortunately, C (and cpp) has no way to make this easy without code > duplication, as we need to va_init() in strbuf_addf() possibly a few > times. So the code for addf() is copied. Fortunately, the code is > pretty short, so not too much had to be copied as-is.
The problem with code duplication is not about code size, but more about not forgetting to fix bugs in all incarnations of the duplicated code.
Is it so ugly to use a macro ?
Mike