Re: [PATCH v2 02/10] midx-write: pass down repository to static functions
- From
Taylor Blau <me@ttaylorr.com>
- Date
- Nov 20, 2024, 19:43 UTC
- Message-ID
- <Zz472iMq3nZMoRMf@nand.local>
- In-Reply-To
- <20241119-374-refactor-midx-c-and-midx-write-c-to-not-depend-on-global-state-v2-2-e2f607174efc@gmail.com>
On Tue, Nov 19, 2024 at 04:36:41PM +0100, Karthik Nayak wrote:
> --- > midx-write.c | 57 +++++++++++++++++++++++++++++++-------------------------- > 1 file changed, 31 insertions(+), 26 deletions(-)
This patch all seems reasonable to me. When reviewing it in this way, it is a little unclear to see which functions need just a repository, just a hash_algo, or the whole write_midx_context structure.
I think I might have erred on the side of just passing the write_midx_context structure throughout the midx-write.c internals. That exposes more of the implementation details than is strictly necessary, but it does so to the benefit of making the code (and this patch) easier to follow.
I don't feel strongly about it, and I trust that you modified the right functions to pass the right data. I just wanted to mention it in case you hadn't considered an alternative way to structure this patch.
Thanks, Taylor