Re: [PATCH v5 05/15] pkt-line: add packet_write_gently_fmt()
- From
Lars Schneider <larsxschneider@gmail.com>
- Date
- Aug 10, 2016, 14:10 UTC
- Message-ID
- <E6D0E830-764D-42E5-9F69-340F718B98B2@gmail.com>
- In-Reply-To
- <20160810134346.6nmf2sudwh56nq76@sigill.intra.peff.net>
Show 23 quoted lines
> On 10 Aug 2016, at 15:43, Jeff King <peff@peff.net> wrote:
>
> On Wed, Aug 10, 2016 at 03:04:01PM +0200, larsxschneider@gmail.com wrote:
>
>> +int packet_write_gently_fmt(int fd, const char *fmt, ...)
>> +{
>> + static struct strbuf buf = STRBUF_INIT;
>> + va_list args;
>> +
>> + strbuf_reset(&buf);
>> + va_start(args, fmt);
>> + format_packet(1, &buf, fmt, args);
>> + va_end(args);
>> + packet_trace(buf.buf + 4, buf.len - 4, 1);
>> + return (write_in_full(fd, buf.buf, buf.len) == buf.len ? 0 : -1);
>> +}
>
> Could the end of this function just be:
>
> return packet_write_gently(fd, buf.buf, buf.len);
>
> ? I guess we'd prefer to avoid that, because it incurs an extra
> memmove() of the data.I don't think the memmove would be that expensive. However, format_packet() already creates the packet_header and packet_write_gently would do the same again, no?
> Similarly, I'd think this could share code with the non-gentle form > (which should be able to just call this and die() if returns an error). > Though sometimes the va_list transformation makes that awkward.
Yeah, the code duplication annoyed me, too. va_list was the reason I did it that way. Do you think that is something that needs to be addressed in the series?
Thanks, Lars