Re: [PATCH v5 04/15] pkt-line: add packet_write_gently()
- From
Jeff King <peff@peff.net>
- Date
- Aug 10, 2016, 13:40 UTC
- Message-ID
- <20160810134003.q6mzgkcrwmkxv5fw@sigill.intra.peff.net>
- In-Reply-To
- <434CB5D7-3FC0-4398-9028-135701121E55@gmail.com>
On Wed, Aug 10, 2016 at 03:36:45PM +0200, Lars Schneider wrote:
Show 8 quoted lines
> > So now we have packet_write() and packet_write_gently(), but they differ > > in more than just whether they are gentle. That seems like a weird > > interface. > > > > Should we either be picking a new name (e.g., packet_write_mem() or > > something), or migrating packet_write() to packet_write_fmt()? > > Done in "[PATCH v5 08/15] pkt-line: rename packet_write() to packet_write_fmt()"
Ah, OK. Generally I'd suggest to reorder things so that each patch looks like a step forward (and so the early patches become preparatory steps, and the justification in them is something like "we're going to add more write functions, so let's give this a more descriptive name").
Show 5 quoted lines
> I agree. In a later patch I am using PKTLINE_DATA_MAXLEN inside pkt-line.c, > too. I will change it to your suggestion. > > For now I would remove PKTLINE_DATA_MAXLEN because it should be an implementation > detail of pkt-line.c (plus it is not used by anyone).
Sounds reasonable.
-Peff