Re: [PATCH v5 04/15] pkt-line: add packet_write_gently()
- From
Jeff King <peff@peff.net>
- Date
- Aug 10, 2016, 13:28 UTC
- Message-ID
- <20160810132814.gqnipsdwyzjmuqjy@sigill.intra.peff.net>
- In-Reply-To
- <20160810130411.12419-5-larsxschneider@gmail.com>
On Wed, Aug 10, 2016 at 03:04:00PM +0200, larsxschneider@gmail.com wrote:
Show 9 quoted lines
> From: Lars Schneider <larsxschneider@gmail.com> > > packet_write() has two shortcomings. First, it uses format_packet() which > lets the caller only send string data via "%s". That means it cannot be > used for arbitrary data that may contain NULs. Second, it will always > die on error. > > Add packet_write_gently() which writes arbitrary data and returns `0` for > success and `-1` for an error.
So now we have packet_write() and packet_write_gently(), but they differ in more than just whether they are gentle. That seems like a weird interface.
Should we either be picking a new name (e.g., packet_write_mem() or something), or migrating packet_write() to packet_write_fmt()?
Show 9 quoted lines
> diff --git a/pkt-line.c b/pkt-line.c > index e6b8410..4f25748 100644 > --- a/pkt-line.c > +++ b/pkt-line.c > @@ -3,6 +3,7 @@ > #include "run-command.h" > > char packet_buffer[LARGE_PACKET_MAX]; > +char packet_write_buffer[LARGE_PACKET_MAX];
Should this be static? I.e., are random other bits of the code allowed to write into it (I guess not because it's not declared in pkt-line.h).
Show 6 quoted lines
> +int packet_write_gently(const int fd_out, const char *buf, size_t size)
> +{
> + if (size > PKTLINE_DATA_MAXLEN)
> + return -1;
> + packet_trace(buf, size, 1);
> + memmove(packet_write_buffer + 4, buf, size);It looks like this iteration drops the idea of callers using a LARGE_PACKET_MAX buffer and only filling it at "buf+4" with PKTLINE_DATA_MAXLEN bytes (which is fine).
I wonder if we still need PKTLINE_DATA_MAXLEN, or of it is just obscuring things. The magic number "4" still appears separately here, and it actually makes it harder to see that things are correct. I.e., doing:
if (size > sizeof(packet_write_buffer) - 4) return -1; memmove(packet_write_buffer + 4, buf, size);
is more obviously correct, because you do not have to wonder about the relationship between the size of your buffer and the macro.
It might still be worth having PKTLINE_DATA_MAXLEN public, though, if callers use it to size their input to packet_write_gently().
-Peff