Re: [PATCH] pack-write: skip *.rev work when not writing *.rev
- From
Carlo Arenas <carenas@gmail.com>
- Date
- Sep 8, 2021, 01:35 UTC
- Message-ID
- <CAPUEspgh0kbm-ro13Xt2-g-hPoBMK2-34iP2GvK_gaa2bGC+GQ@mail.gmail.com>
- In-Reply-To
- <patch-1.1-366ba928bd-20210908T010743Z-avarab@gmail.com>
On Tue, Sep 7, 2021 at 6:10 PM Ævar Arnfjörð Bjarmason <avarab@gmail.com> wrote:
> + if (!(flags & WRITE_REV) && !(flags & WRITE_REV_VERIFY)) > + return NULL;
I see this expression matches exactly the logic from 8ef50d9958 which is why I presume you used it, but the simpler (and logically equivalent[1]) :
if !((flags & WRITE_REV) || (flags & WRITE_REV_VERIFY))
is easier to read IMHO
Carlo
[1] https://en.wikipedia.org/wiki/De_Morgan%27s_laws