From: Carlo Arenas Date: Wed, 08 Sep 2021 01:35:10 GMT Subject: Re: [PATCH] pack-write: skip *.rev work when not writing *.rev Message-ID: In-Reply-To: On Tue, Sep 7, 2021 at 6:10 PM Ævar Arnfjörð Bjarmason wrote: > + if (!(flags & WRITE_REV) && !(flags & WRITE_REV_VERIFY)) > + return NULL; I see this expression matches exactly the logic from 8ef50d9958 which is why I presume you used it, but the simpler (and logically equivalent[1]) : if !((flags & WRITE_REV) || (flags & WRITE_REV_VERIFY)) is easier to read IMHO Carlo [1] https://en.wikipedia.org/wiki/De_Morgan%27s_laws