Re: [PATCH 4/4] builtin/branch: strip refs/heads/ using skip_prefix
- From
Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
- Date
- Nov 19, 2017, 17:21 UTC
- Message-ID
- <a3bba8dc-0f4c-808c-9b6e-2252160a2cc1@gmail.com>
- In-Reply-To
- <CAPig+cRrJVhYMYfoFhSi+FOLv0X4or1-YV=M8_X10_d_Bbt3pA@mail.gmail.com>
On Sunday 19 November 2017 06:34 AM, Eric Sunshine wrote:
Show 12 quoted lines
> On Sat, Nov 18, 2017 at 12:26 PM, Kaartic Sivaraam
> <kaartic.sivaraam@gmail.com> wrote:
>> diff --git a/builtin/branch.c b/builtin/branch.c
>> @@ -462,6 +462,8 @@ static void copy_or_rename_branch(const char *oldname, const char *newname, int
>> {
>> struct strbuf oldref = STRBUF_INIT, newref = STRBUF_INIT, logmsg = STRBUF_INIT;
>> struct strbuf oldsection = STRBUF_INIT, newsection = STRBUF_INIT;
>> + const char *prefix_free_oldref = NULL;
>> + const char *prefix_free_newref = NULL;
>
> A bit of a mouthful.
> Quite possibly.
> Perhaps name these 'oldname' and 'newname' or something?
How about the following ?
1) "interpreted_oldname" and "interpreted_newname" or
2) "stripped_oldref" and "stripped_newref"
I couldn't come up with better names for now.
--- Kaartic