Re: [RFC PATCH 3/5] branch: cleanup branch name validation
- From
Kaartic Sivaraam <kaarticsivaraam91196@gmail.com>
- Date
- Sep 20, 2017, 14:52 UTC
- Message-ID
- <aaffe492-75bc-c898-1ab2-271f9f8c9e17@gmail.com>
- In-Reply-To
- <xmqqzi9qngq9.fsf@gitster.mtv.corp.google.com>
On Wednesday 20 September 2017 09:50 AM, Junio C Hamano wrote:
Show 7 quoted lines
> Also I'd avoid "could", which can be taken as an optimization hint > (i.e. "you usually do not have to worry about this thing to already > exist, but I am telling you that for this one call that is not the > case and you need to be a bit more careful by spending extra cycles > to see if it is and deal with the situation accordingly if it indeed > is"), and use "ok" as part of the name for the parameter (or flip > the meaning of it and say "create_only" or something).
Consider I'm gonna replace 'force' with a parameter that has the flipped meaning. Does 'shouldnt_exist' seem to be a good name for this new parameter?