From: Kaartic Sivaraam Date: Sun, 19 Nov 2017 17:21:59 GMT Subject: Re: [PATCH 4/4] builtin/branch: strip refs/heads/ using skip_prefix Message-ID: In-Reply-To: On Sunday 19 November 2017 06:34 AM, Eric Sunshine wrote: > On Sat, Nov 18, 2017 at 12:26 PM, Kaartic Sivaraam > wrote: >> diff --git a/builtin/branch.c b/builtin/branch.c >> @@ -462,6 +462,8 @@ static void copy_or_rename_branch(const char *oldname, const char *newname, int >> { >> struct strbuf oldref = STRBUF_INIT, newref = STRBUF_INIT, logmsg = STRBUF_INIT; >> struct strbuf oldsection = STRBUF_INIT, newsection = STRBUF_INIT; >> + const char *prefix_free_oldref = NULL; >> + const char *prefix_free_newref = NULL; > > A bit of a mouthful. > Quite possibly. > Perhaps name these 'oldname' and 'newname' or something? How about the following ? 1) "interpreted_oldname" and "interpreted_newname" or 2) "stripped_oldref" and "stripped_newref" I couldn't come up with better names for now. --- Kaartic