git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [RFC PATCH 0/2] upload-pack.c: limit allowed filter choices

From
Taylor Blau <me@ttaylorr.com>
Date
Apr 22, 2020, 20:41 UTC
Message-ID
<20200422204114.GA4850@syl.local>
In-Reply-To
<CAP8UFD0kqSQAnpfUxqDn_qwigQZhq7zyxY_CZhd1nJzqHT1cqw@mail.gmail.com>
On Tue, Apr 21, 2020 at 02:34:18PM +0200, Christian Couder wrote:
Show 49 quoted lines
> On Fri, Apr 17, 2020 at 8:06 PM Jeff King <peff@peff.net> wrote:
> >
> > On Fri, Apr 17, 2020 at 11:40:30AM -0600, Taylor Blau wrote:
> >
> > > > What do you think about something like:
> > > >
> > > > [promisorFilter "noBlobs"]
> > > >         type = blob:none
> > > >         uploadpack = true # maybe "allow" could also mean "true" here
> > > >         ...
> > > > ?
> > >
> > > I'm not sure about introducing a layer of indirection here with
> > > "noBlobs". It's nice that it could perhaps be enabled/disabled for
> > > different builtins (e.g., by adding 'revList = false', say), but I'm not
> > > convinced that this is improving all of those cases, either.
> >
> > Yeah, I don't like forcing the user to invent a subsection name. My
> > first thought was to suggest:
> >
> >   [promisorFilter "blob:none"]
> >   uploadpack = true
> >
> > but your tree example shows why that gets awkward: there are more keys
> > than just "allow this".
>
> I like your first thought better than something that starts with
> "uploadPack". And I think if we let people find a subsection name (as
> what I suggest) they might indeed end up with something like:
>
> [promisorFilter "blob:none"]
>      type = blob:none
>      uploadpack = true
>
> as they might lack inspiration. As filters are becoming more and more
> complex though, people might find it much simpler to use the
> subsection name in commands if we let them do that. For example we
> already allow:
>
> git rev-list --filter=combine:<filter1>+<filter2>+...<filterN> ...
>
> which could be simplified to:
>
> git rev-list --filter=combinedFilter ...
>
> (where "combinedFilter" is defined in the config with
> "type=combine:<filter1>+<filter2>+...<filterN>".)
>
> [...]

I really think that we're getting ahead of ourselves here. For now, I don't think that we have powerful enough filters that it makes sense to put them together with combine and give them meaningful names. At least, no one has asked about such a thing on the list, which I take to mean that people don't have a use for it.

I'm also skeptical about relying on named filters when working with a server. If the server defines the filter names (as we at GitHub would do under this proposal), then what use are they to the client? For the server, I'm not at all convinced that this is beneficial: the extra layer of indirection through the configuration makes this brittle and hard-to-follow.

Not to mention that the server could just as easily spell out the whole filter.

I'm not trying to give you a too-simple proposal, but I think yours introduces additional complexity that is trying to enable use-cases that we don't have in practice.

Show 14 quoted lines
> > > We're not using them, but without them we suffer from a problem that if
> > > we can get a SIGPIPE when writing the "sorry, I don't support that
> > > filter" message back to the client, then they won't receive it.
> > >
> > > Szeder's patches help address that issue by catching the SIGPIPE and
> > > popping off enough from the client buffer so that we can write the
> > > message out before dying.
> >
> > I definitely think we should pursue that patch, but it really can be
> > done orthogonally. It's an existing bug that affects other instances
> > where upload-pack returns an error. The tests can work around it with
> > "test_must_fail ok=sigpipe" in the meantime.
>
> Ok, maybe I will take a look a this one then.
Thanks.
> Thanks,
> Christian.

Thanks, Taylor

Previous: Christian CouderNext: Taylor Blau
Message 78 of 106 in “Notes from Git Contributor Summit, Los Angeles (April 5, 2020)”
  1. James RamsayMar 12, 2020
  2. 1/17 ReftableJames Ramsay, Mar 12, 2020
  3. 2/17 Hooks in the futureJames Ramsay, Mar 12, 2020
  4. Emily ShafferMar 12, 2020
  5. Junio C HamanoMar 13, 2020
  6. Emily ShafferApr 7, 2020
  7. Emily ShafferApr 7, 2020
  8. Junio C HamanoApr 8, 2020
  9. Emily ShafferApr 8, 2020
  10. Jeff KingApr 10, 2020
  11. Emily ShafferApr 13, 2020
  12. Jeff KingApr 13, 2020
  13. 0/2 configuration-based hook management (was: [TOPIC 2/17] Hooks in the future)Emily Shaffer, Apr 14, 2020
  14. 1/2 hook: scaffolding for git-hook subcommandEmily Shaffer, Apr 14, 2020
  15. 2/2 hook: add --list modeEmily Shaffer, Apr 14, 2020
  16. Phillip WoodApr 14, 2020
  17. Emily ShafferApr 14, 2020
  18. Jeff KingApr 14, 2020
  19. Phillip WoodApr 15, 2020
  20. Josh SteadmonApr 14, 2020
  21. Phillip WoodApr 15, 2020
  22. Jeff KingApr 14, 2020
  23. Phillip WoodApr 15, 2020
  24. Junio C HamanoApr 15, 2020
  25. Emily ShafferApr 15, 2020
  26. Junio C HamanoApr 15, 2020
  27. Jonathan NiederApr 15, 2020
  28. Emily ShafferApr 15, 2020
  29. doc: propose hooks managed by the configEmily Shaffer, Apr 20, 2020
  30. Emily ShafferApr 21, 2020
  31. Junio C HamanoApr 21, 2020
  32. Emily ShafferApr 24, 2020
  33. brian m. carlsonApr 25, 2020
  34. Emily ShafferMay 6, 2020
  35. brian m. carlsonMay 6, 2020
  36. Emily ShafferMay 19, 2020
  37. Jeff KingApr 15, 2020
  38. Emily ShafferApr 15, 2020
  39. Jeff KingApr 15, 2020
  40. 3/17 ObliterateJames Ramsay, Mar 12, 2020
  41. Konstantin RyabitsevMar 12, 2020
  42. Damien RobertMar 15, 2020
  43. Konstantin TokarevMar 16, 2020
  44. Damien RobertMar 26, 2020
  45. Elijah NewrenMar 16, 2020
  46. Damien RobertMar 26, 2020
  47. Phillip SusiMar 16, 2020
  48. Damien RobertMar 26, 2020
  49. Philip OakleyMar 16, 2020
  50. nbelakovski@gmail.comMay 16, 2020
  51. 4/17 Sparse checkoutJames Ramsay, Mar 12, 2020
  52. 5/17 Partial CloneJames Ramsay, Mar 12, 2020
  53. Allowing only blob filtering was: [TOPIC 5/17] Partial CloneChristian Couder, Mar 17, 2020
  54. 0/2 upload-pack.c: limit allowed filter choicesTaylor Blau, Mar 17, 2020
  55. 1/2 list_objects_filter_options: introduce 'list_object_filter_config_name'Taylor Blau, Mar 17, 2020
  56. Eric SunshineMar 17, 2020
  57. Jeff KingMar 18, 2020
  58. Junio C HamanoMar 18, 2020
  59. Eric SunshineMar 18, 2020
  60. Jeff KingMar 19, 2020
  61. Taylor BlauMar 18, 2020
  62. 2/2 upload-pack.c: allow banning certain object filter(s)Taylor Blau, Mar 17, 2020
  63. Eric SunshineMar 17, 2020
  64. Taylor BlauMar 18, 2020
  65. Philip OakleyMar 18, 2020
  66. Taylor BlauMar 18, 2020
  67. Jeff KingMar 18, 2020
  68. Re*: [RFC PATCH 0/2] upload-pack.c: limit allowed filter choicesJunio C Hamano, Mar 18, 2020
  69. Jeff KingMar 19, 2020
  70. Taylor BlauMar 18, 2020
  71. Junio C HamanoMar 18, 2020
  72. Jeff KingMar 19, 2020
  73. Jeff KingMar 19, 2020
  74. Christian CouderApr 17, 2020
  75. Taylor BlauApr 17, 2020
  76. Jeff KingApr 17, 2020
  77. Christian CouderApr 21, 2020
  78. Taylor BlauApr 22, 2020
  79. Taylor BlauApr 22, 2020
  80. Christian CouderApr 21, 2020
  81. 6/17 GC strategiesJames Ramsay, Mar 12, 2020
  82. 7/17 Background operations/maintenanceJames Ramsay, Mar 12, 2020
  83. 8/17 Push performanceJames Ramsay, Mar 12, 2020
  84. 9/17 Obsolescence markers and evolveJames Ramsay, Mar 12, 2020
  85. Noam SoloveichikMay 9, 2020
  86. Jeff KingMay 15, 2020
  87. 10/17 Expel ‘git shell’?James Ramsay, Mar 12, 2020
  88. 11/17 GPL enforcementJames Ramsay, Mar 12, 2020
  89. 12/17 Test harness improvementsJames Ramsay, Mar 12, 2020
  90. 13/17 Cross implementation test suiteJames Ramsay, Mar 12, 2020
  91. 14/17 Aspects of merge-ort: cool, or crimes against humanity?James Ramsay, Mar 12, 2020
  92. 15/17 Reachability checksJames Ramsay, Mar 12, 2020
  93. 16/17 “I want a reviewer”James Ramsay, Mar 12, 2020
  94. Emily ShafferMar 12, 2020
  95. Konstantin RyabitsevMar 12, 2020
  96. Jonathan NiederMar 12, 2020
  97. Konstantin RyabitsevMar 12, 2020
  98. Philippe BlainMar 17, 2020
  99. Eric WongMar 13, 2020
  100. Jeff KingMar 14, 2020
  101. inbox indexing wishlist [was: [TOPIC 16/17] “I want a reviewer”]Eric Wong, Mar 15, 2020
  102. 17/17 SecurityJames Ramsay, Mar 12, 2020
  103. Derrick StoleeMar 12, 2020
  104. Jeff KingMar 13, 2020
  105. Jakub NarebskiMar 15, 2020
  106. Jeff KingMar 16, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.