Re: [PATCH 12/16] git-submodule: avoid sed input with no newline
- From
Jeff King <peff@peff.net>
- Date
- Mar 13, 2008, 12:46 UTC
- Message-ID
- <20080313124614.GE19485@coredump.intra.peff.net>
- In-Reply-To
- <7vabl34lc0.fsf@gitster.siamese.dyndns.org>
On Wed, Mar 12, 2008 at 03:41:03PM -0700, Junio C Hamano wrote:
Show 7 quoted lines
> Good use of --literal. > > But doesn't this make you wonder if "--literal-match --get-regexp" is > quite a strange combination? "Literal" covers the value part but the key > is still regexp (and we do want it to behave that way). However, maybe we > would want to also allow "give entries whose key is this literal key and > whose value matches this regexp"?
git config --get?
The problem is that we are matching on two elements: key and value. The matching style of the key element is chosen by --get versus --get-regexp. However, the value_regex is selected implicitly by its presence, so there is no room to modify the flag in the same way. Perhaps --literal-value-match or just --literal-value would be a better name.
-Peff