Shourya Shukla
@periperidip on GitHub. Posts as shouryashukla.oo@gmail.com.
221
messages
118
patches posted
73%
of 11 series merged
53
threads started
2020
first message, Jan 16, 2020
Jun 4, 2021
since the latest message
Patch series
Of 11 patch series (re-rolls counted once), 8 landed on master and 3 did not.
- not mergedsubmodule: port subcommand add from shell to Cv2, Oct 7, 2020
- mergedsubmodule: fixup to summary-v3v2, Aug 27, 2020, f0c6b6467d
- mergedt7401: modernize, cleanup and morev3, Aug 21, 2020, 94e06c9057
- mergedsubmodule: port subcommand 'summary' from shell to Cv3, Aug 12, 2020, 180b154b09
- mergedsubmodule: port subcommand 'set-branch' from shell to Cv5, Jun 2, 2020, 2964d6e5e1
- mergedsubmodule: port subcommand 'set-url' from shell to Cv5, May 8, 2020, 6417cf9c21
- mergedgitfaq: files in .gitignore are trackedv7, May 6, 2020, 60e523632f
- not mergedupdate gitfaqv2, Apr 13, 2020
- mergedsubmodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'v2, Apr 2, 2020, d00a5bdd50
- not merged[RFC][GSoC] submodule: enforcing stricter checksFeb 11, 2020
- mergedt6025: updating testsv3, Jan 18, 2020, 70789843bd
A series is merged when one of its patches matches a commit on master by the same author, by subject. Versions are linked when they share a patch subject. Patches reworded before landing, or applied under someone else's name, count as not merged.
Recent emails
- Re: [PATCH v2] [GSoC] submodule--helper: introduce add-clone subcommand
- Re: [Outreachy-Microproject][PATCH 1/1] t0000: replace 'test -[def]' with helpers
- Re: [PATCH v2 1/3] dir: change the scope of function 'directory_exists_in_index()'
- t7400: add test to check 'submodule add' for tracked paths
- submodule: port submodule subcommand 'add' from shell to C
- dir: change the scope of function 'directory_exists_in_index()'
- submodule: port subcommand add from shell to C
- Re: Git in Outreachy?
- Re: [GSoC][PATCH] submodule: port submodule subcommand 'add' from shell to C
- Re: [GSoC][PATCH] submodule: port submodule subcommand 'add' from shell to C
- t7421: eliminate 'grep' check in t7421.4 for mingw compatibility
- submodule: fix style in function definition
- submodule: eliminate unused parameters from print_submodule_summary()
- submodule: fixup to summary-v3
- Re: [PATCH 3/3] t7421: eliminate 'grep' check in t7421.4 for mingw compatibility
- Re: [PATCH 3/3] t7421: eliminate 'grep' check in t7421.4 for mingw compatibility
- Re: [PATCH 2/3] submodule: fix style in function definition
- Re: [GSoC][PATCH] submodule: port submodule subcommand 'add' from shell to C
- Re: [GSoC][PATCH] submodule: port submodule subcommand 'add' from shell to C
- t7421: eliminate 'grep' check in t7421.4 for mingw compatibility
- submodule: eliminate unused parameters from print_submodule_summary()
- submodule: fix style in function definition
- submodule: fixup to summary-v3
- Re: [PATCH v3 4/4] submodule: port submodule subcommand 'summary' from shell to C
- Re: [PATCH v3 4/4] submodule: port submodule subcommand 'summary' from shell to C
- submodule: port submodule subcommand 'add' from shell to C
- [GSoC] Shourya's Blog
- Re: [PATCH v3 4/4] submodule: port submodule subcommand 'summary' from shell to C
- Re: [PATCH v3 4/4] submodule: port submodule subcommand 'summary' from shell to C
- t7401: modernize, cleanup and more