git/list[1] front-page[2] threads[3] people[4] search[5] about
 

[PATCH 2/3] submodule: fix style in function definition

From
Shourya Shukla <shouryashukla.oo@gmail.com>
Date
Aug 25, 2020, 11:30 UTC
Message-ID
<20200825113020.71801-3-shouryashukla.oo@gmail.com>
In-Reply-To
<20200825113020.71801-1-shouryashukla.oo@gmail.com>

The definitions of 'verify_submodule_committish()' and 'print_submodule_summary()' had wrong styling in terms of the asterisk placement. Amend them.

Also, the warning printed in case of an unexpected file mode printed the mode in decimal. Print it in octal for enhanced readability.

Reported-by: Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
Mentored-by: Christian Couder <chriscool@tuxfamily.org>
Mentored-by: Kaartic Sivaraam <kaartic.sivaraam@gmail.com>
Helped-by: Junio C Hamano <gitster@pobox.com>
Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com>
---
 builtin/submodule--helper.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c
index b83f840251..93d0700891 100644
--- a/builtin/submodule--helper.c
+++ b/builtin/submodule--helper.c
@@ -959,7 +959,7 @@ enum diff_cmd {
 	DIFF_FILES
 };
 
-static char* verify_submodule_committish(const char *sm_path,
+static char *verify_submodule_committish(const char *sm_path,
 					 const char *committish)
 {
 	struct child_process cp_rev_parse = CHILD_PROCESS_INIT;
@@ -979,7 +979,7 @@ static char* verify_submodule_committish(const char *sm_path,
 	return strbuf_detach(&result, NULL);
 }
 
-static void print_submodule_summary(struct summary_cb *info, char* errmsg,
+static void print_submodule_summary(struct summary_cb *info, char *errmsg,
 				    int total_commits, const char *displaypath,
 				    const char *src_abbrev, const char *dst_abbrev,
 				    struct module_cb *p)
@@ -1056,7 +1056,7 @@ static void generate_submodule_summary(struct summary_cb *info,
 		} else {
 			/* for a submodule removal (mode:0000000), don't warn */
 			if (p->mod_dst)
-				warning(_("unexpected mode %d\n"), p->mod_dst);
+				warning(_("unexpected mode %o\n"), p->mod_dst);
 		}
 	}
 
-- 
2.28.0
Previous: Shourya ShuklaNext: Junio C Hamano
Message 2 of 12 in “submodule: fixup to summary-v3”
  1. Shourya ShuklaAug 25, 2020
  2. 2/3 submodule: fix style in function definitionShourya Shukla, Aug 25, 2020
  3. Junio C HamanoAug 25, 2020
  4. Shourya ShuklaAug 26, 2020
  5. Junio C HamanoAug 26, 2020
  6. 1/3 submodule: eliminate unused parameters from print_submodule_summary()Shourya Shukla, Aug 25, 2020
  7. 3/3 t7421: eliminate 'grep' check in t7421.4 for mingw compatibilityShourya Shukla, Aug 25, 2020
  8. Kaartic SivaraamAug 25, 2020
  9. Junio C HamanoAug 25, 2020
  10. Shourya ShuklaAug 27, 2020
  11. Shourya ShuklaAug 26, 2020
  12. Kaartic SivaraamAug 25, 2020

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.