threads / patch / 53160

patchsubmodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

Subject: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

## tl;dr

5 messages between Apr 2, 2020 and Apr 3, 2020. Diffs are folded; open one to read it.

replies: 4people: 2as markdown or json

Shourya Shukla· Apr 2, 2020, 22:58 UTC · lore

Subcommands in 'submodule--helper.c' which give a callback to other functions have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT' respectively.

The subcommand 'foreach' did not follow this convention and therefore had the naming of the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb' and 'FOREACH_CB_INIT' respectively.

Shourya Shukla (1):
  submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
-- 
2.20.1
Shourya Shukla· Apr 2, 2020, 22:58 UTC · re: Shourya Shukla · lore

[PATCH 1/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

In 'submodule--helper.c', the structures and macros for callbacks belonging to any subcommand are named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT' respectively.

This was an exception for the subcommand 'foreach' of the command 'submodule'. Rename the aforementioned structures and macros: 'struct cb_foreach' to 'struct foreach_cb' and 'CB_FOREACH_INIT' to 'FOREACH_CB_INIT'.

Signed-off-by: Shourya Shukla <shouryashukla.oo@gmail.com>
---
 builtin/submodule--helper.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
Show changes to builtin/submodule--helper.c +4 −4
diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c
index 7d5996d3b3..a21e48730d 100644
--- a/builtin/submodule--helper.c
+++ b/builtin/submodule--helper.c
@@ -444,19 +444,19 @@ static void for_each_listed_submodule(const struct module_list *list,
 		fn(list->entries[i], cb_data);
 }
 
-struct cb_foreach {
+struct foreach_cb {
 	int argc;
 	const char **argv;
 	const char *prefix;
 	int quiet;
 	int recursive;
 };
-#define CB_FOREACH_INIT { 0 }
+#define FOREACH_CB_INIT { 0 }
 
 static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 				       void *cb_data)
 {
-	struct cb_foreach *info = cb_data;
+	struct foreach_cb *info = cb_data;
 	const char *path = list_item->name;
 	const struct object_id *ce_oid = &list_item->oid;
 
@@ -557,7 +557,7 @@ static void runcommand_in_submodule_cb(const struct cache_entry *list_item,
 
 static int module_foreach(int argc, const char **argv, const char *prefix)
 {
-	struct cb_foreach info = CB_FOREACH_INIT;
+	struct foreach_cb info = FOREACH_CB_INIT;
 	struct pathspec pathspec;
 	struct module_list list = MODULE_LIST_INIT;
 
-- 
2.20.1
Junio C Hamano· Apr 3, 2020, 00:20 UTC · re: Shourya Shukla · lore

Re: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

Shourya Shukla <shouryashukla.oo@gmail.com> writes:
Show 14 quoted lines
> Subcommands in 'submodule--helper.c' which give a callback to other functions
> have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
> respectively.
>
> The subcommand 'foreach' did not follow this convention and therefore had the naming of
> the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb'
> and 'FOREACH_CB_INIT' respectively.
>
>
> Shourya Shukla (1):
>   submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
>
>  builtin/submodule--helper.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
Isn't this already in 'master'?
Shourya Shukla· Apr 3, 2020, 06:01 UTC · re: Junio C Hamano · lore

Re: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

I apologize. I did not notice that my patch was merged.

Regards, Shourya Shukla

On Fri, Apr 3, 2020 at 5:50 AM Junio C Hamano <gitster@pobox.com> wrote:
Show 20 quoted lines
>
> Shourya Shukla <shouryashukla.oo@gmail.com> writes:
>
> > Subcommands in 'submodule--helper.c' which give a callback to other functions
> > have structures and macros named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT'
> > respectively.
> >
> > The subcommand 'foreach' did not follow this convention and therefore had the naming of
> > the form: 'struct foreach_cb' and 'CB_FOREACH_INIT'. Rename these to: 'struct foreach_cb'
> > and 'FOREACH_CB_INIT' respectively.
> >
> >
> > Shourya Shukla (1):
> >   submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'
> >
> >  builtin/submodule--helper.c | 8 ++++----
> >  1 file changed, 4 insertions(+), 4 deletions(-)
>
> Isn't this already in 'master'?
>
Junio C Hamano· Apr 3, 2020, 17:58 UTC · re: Shourya Shukla · lore

Re: [PATCH 0/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb'

Shourya Shukla <shouryashukla.oo@gmail.com> writes:
> I apologize. I did not notice that my patch was merged.

No need to be sorry ;-) Thanks for contributing, and keep the good patches coming!

← back to recent threads