Re: [PATCH v2 1/2] cat-file: rename cmdmode to transform_mode
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Feb 7, 2022, 23:58 UTC
- Message-ID
- <xmqqo83ifcv0.fsf@gitster.g>
- In-Reply-To
- <2d9a0b06ce5ab62095ae9a91d8d56441e9bb8c54.1644251611.git.gitgitgadget@gmail.com>
"John Cai via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 9 quoted lines
> From: John Cai <johncai86@gmail.com> > > When introducing a new flag --batch-command, we will add a flag on the > batch_options struct that indicates whether or not an interactive > command mode will be used that reads commands and arguments off of > stdin. > > An intuitive name for this flag would be "command", which can get > confusing with the already existing cmdmode.
Is "command" truly an intuitive name for "were we given '--batch-command' option?" bit? I dunno.
But I agree that "transform_mode" is much better name than "cmdmode" for what this member is about.