git/list[1] front-page[2] threads[3] people[4] search[5] about
 

Re: [PATCH v2 2/2] cat-file: add --batch-command mode

From
Junio C Hamano <gitster@pobox.com>
Date
Feb 8, 2022, 00:49 UTC
Message-ID
<xmqq35kufahb.fsf@gitster.g>
In-Reply-To
<1b63164ad4d9ec6b5fa6f733b6095b2779298b36.1644251611.git.gitgitgadget@gmail.com>
"John Cai via GitGitGadget" <gitgitgadget@gmail.com> writes:
Show 24 quoted lines
> From: John Cai <johncai86@gmail.com>
>
> Add a new flag --batch-command that accepts commands and arguments
> from stdin, similar to git-update-ref --stdin.
>
> At GitLab, we use a pair of long running cat-file processes when
> accessing object content. One for iterating over object metadata with
> --batch-check, and the other to grab object contents with --batch.
>
> However, if we had --batch-command, we wouldn't need to keep both
> processes around, and instead just have one --batch-command process
> where we can flip between getting object info, and getting object
> contents. Since we have a pair of cat-file processes per repository,
> this means we can get rid of roughly half of long lived git cat-file
> processes. Given there are many repositories being accessed at any given
> time, this can lead to huge savings since on a given server.
>
> git cat-file --batch-command
>
> will enter an interactive command mode whereby the user can enter in
> commands and their arguments that get queued in memory:
>
> <command1> [arg1] [arg2] NL
> <command2> [arg1] [arg2] NL

If you mean you take one command with its args per line, use LF not NL.

    $ git grep '\<NL\>' Documentation
    $ git grep '\<LF\>' Documentation

We may want to fix the sole offender in Documentation/config.txt file (#leftoverbits).

> With this mechanism of queueing up commands and letting (A) issue a
> flush command, process (A) can control when the buffer is flushed and
> can guarantee it will receive all of the output when in --buffer mode.

Are we giving them guarantee when output will *not* come? If (B) is allowed to flush when it thinks it has too much in-core, it would mean that (A) cannot keep issuing commands forever without reading the response from (B), because (B) will eventually be blocked when it tries to flush to a pipe that (A) is not reading. I think there should be some discussion on that, too. IOW, --batch-command does not allow (B) to flush until it gets "flush", or something like that.

Show 17 quoted lines
> diff --git a/Documentation/git-cat-file.txt b/Documentation/git-cat-file.txt
> index bef76f4dd06..618dbd15338 100644
> --- a/Documentation/git-cat-file.txt
> +++ b/Documentation/git-cat-file.txt
> @@ -96,6 +96,25 @@ OPTIONS
>  	need to specify the path, separated by whitespace.  See the
>  	section `BATCH OUTPUT` below for details.
>  
> +--batch-command::
> +	Enter a command mode that reads commands and arguments from stdin.
> +	May not be combined with any other options or arguments except
> +	`--textconv` or `--filters`, in which case the input lines also need to
> +	specify the path, separated by whitespace.  See the section
> +	`BATCH OUTPUT` below for details.
> +
> +contents <object>::
> +	Print object contents for object reference <object>
Presumably this corresponds to what you get out of "--batch"?
> +info <object>::
> +	Print object info for object reference <object>
and this one "--batch-check"?

I expect that future readers will ask this same question because it is not clear how "object contents" and "object info" are exactly printed. These two paragraphs may want to anticipate it and reduce the need for readers to ask such a question.

Show 5 quoted lines
> +flush::
> +	Execute all preceding commands that were issued since the beginning or
> +	since the last flush command was issued. Only used with --buffer. When
> +	--buffer is not used, commands are flushed each time without issuing
> +	`flush`.

Here is a good place to also say "When --buffer is used, no output will come until this is issued" or something.

Show 9 quoted lines
> diff --git a/builtin/cat-file.c b/builtin/cat-file.c
> index 5f015e71096..6bfab74b58a 100644
> --- a/builtin/cat-file.c
> +++ b/builtin/cat-file.c
> @@ -26,6 +26,7 @@ struct batch_options {
>  	int unordered;
>  	int transform_mode; /* may be 'w' or 'c' for --filters or --textconv */
>  	const char *format;
> +	int command;

I am not sure if "command" is a good name. Does it answer this question clearly? "'command' as opposed to what?"

Show 29 quoted lines
> @@ -508,6 +509,118 @@ static int batch_unordered_packed(const struct object_id *oid,
>  				      data);
>  }
>  
> +typedef void (*parse_cmd_fn_t)(struct batch_options *, const char *,
> +			       struct strbuf *, struct expand_data *);
> +
> +struct queued_cmd {
> +	parse_cmd_fn_t fn;
> +	const char *line;
> +};
> +
> +static void parse_cmd_contents(struct batch_options *opt,
> +			     const char *line,
> +			     struct strbuf *output,
> +			     struct expand_data *data)
> +{
> +	opt->print_contents = 1;
> +	batch_one_object(line, output, opt, data);
> +}
> +
> +static void parse_cmd_info(struct batch_options *opt,
> +			   const char *line,
> +			   struct strbuf *output,
> +			   struct expand_data *data)
> +{
> +	opt->print_contents = 0;
> +	batch_one_object(line, output, opt, data);
> +}
OK, these are as simple as expected.
Show 8 quoted lines
> +static void flush_batch_calls(struct batch_options *opt,
> +		struct strbuf *output,
> +		struct expand_data *data,
> +		struct queued_cmd *cmds,
> +		int queued)
> +{
> +	int i;
> +	for(i = 0; i < queued; i++){
Missing SP around parentheses.
Excess brace pair wround a single-statement block.
Show 41 quoted lines
> +		cmds[i].fn(opt, cmds[i].line, output, data);
> +	}
> +	fflush(stdout);
> +}
> +
> +static const struct parse_cmd {
> +	const char *prefix;
> +	parse_cmd_fn_t fn;
> +	unsigned takes_args;
> +} commands[] = {
> +	{ "contents", parse_cmd_contents, 1},
> +	{ "info", parse_cmd_info, 1},
> +};
> +
> +static void batch_objects_command(struct batch_options *opt,
> +				    struct strbuf *output,
> +				    struct expand_data *data)
> +{
> +	struct strbuf input = STRBUF_INIT;
> +	struct queued_cmd *cmds = NULL;
> +	size_t alloc = 0, nr = 0;
> +	int queued = 0;
> +
> +	while (!strbuf_getline(&input, stdin)) {
> +		int i;
> +		const struct parse_cmd *cmd = NULL;
> +		const char *p, *cmd_end;
> +		struct queued_cmd call = {0};
> +
> +		if (!input.len)
> +			die(_("empty command in input"));
> +		if (isspace(*input.buf))
> +			die(_("whitespace before command: '%s'"), input.buf);
> +
> +		if (skip_prefix(input.buf, "flush", &cmd_end)) {
> +			if (!opt->buffer_output)
> +				die(_("flush is only for --buffer mode"));
> +			if (*cmd_end)
> +				die(_("flush takes no arguments"));
> +			if (!queued)
> +				die(_("nothing to flush"));

I am not sure if this is a good idea at all. What do we gain from punishing an automated stupid loop that issues flush every once in a while after issuing a handful real commands and issues another flush after running out of the real commands for a good measure?

Show 12 quoted lines
> +			flush_batch_calls(opt, output, data, cmds, queued);
> +			queued = 0;
> +			continue;
> +		}
> +
> +		for (i = 0; i < ARRAY_SIZE(commands); i++) {
> +			if (!skip_prefix(input.buf, commands[i].prefix, &cmd_end))
> +				continue;
> +
> +			cmd = &commands[i];
> +			if (cmd->takes_args)
> +				p = cmd_end + 1;

If somebody adds an entry with .takes_args==false, p will stay uninitialized and used in the call ->fn() below, or passed to xstrdup(p). It probabloy should be initialized to NULL, and xstrdup(p) below replaced with xstrdup_or_null(p).

Show 11 quoted lines
> +			break;
> +		}
> +
> +		if (!cmd)
> +			die(_("unknown command: '%s'"), input.buf);
> +
> +		if (!opt->buffer_output) {
> +			cmd->fn(opt, p, output, data);
> +			continue;
> +		}
> +
Show 9 quoted lines
> +		queued++;
> +		if (queued > nr) {
> +			ALLOC_GROW(cmds, nr+1, alloc);
> +			nr++;
> +		}
> +
> +		call.fn = cmd->fn;
> +		call.line = xstrdup(p);
> +		cmds[queued-1] = call;
Can nr and queued ever go out of sync?

If cmds is the usual <array, nr, alloc> tuple we let ALLOC_GROW() to manage, alloc keeps track of how physically large the array is, and nr indicates how many slots are filled. Holding onto the block of memory we used when discarding the accumulated items and reusing that block without having to reallocate until we use the slots that we have allocated is done by using only <nr, alloc> pair.

But the above code seems that it does not understand that, and instead thinks it has to use "nr" for the "we have made the array this big, so we do not have to realloc up to that point" pointer, hence its use of a separate "queued". IOW, the array growing code above seems confused.

It is more customery (hence easier to follow by readers who work on our code base) to lose queued and say

		ALLOC_GROW(cmds, nr + 1, alloc);
		cmds[nr++] = call;
		call.fn = cmd->fn;
		call.line = xstrdup_or_null(p);
instead of the above 9 lines.
Show 5 quoted lines
> @@ -515,6 +628,7 @@ static int batch_objects(struct batch_options *opt)
>  	struct expand_data data;
>  	int save_warning;
>  	int retval = 0;
> +	const int command = opt->command;

This tells me that it is quite a misnomer. This single bit is used to differentiate between "other batch modes" and "--batch-command" mode, which already smells like a misdesign, because we have, from an end-user's point of view, three modes:

    --batch
    --batch-check
    --batch-command

so it would be far cleaner to have a single batch_mode enum that can represent these three "batch modes", no?

Show 26 quoted lines
>  	if (!opt->format)
>  		opt->format = "%(objectname) %(objecttype) %(objectsize)";
> @@ -590,6 +704,10 @@ static int batch_objects(struct batch_options *opt)
>  	save_warning = warn_on_object_refname_ambiguity;
>  	warn_on_object_refname_ambiguity = 0;
>  
> +	if (command) {
> +		batch_objects_command(opt, &output, &data);
> +		goto cleanup;
> +	}
>  	while (strbuf_getline(&input, stdin) != EOF) {
>  		if (data.split_on_whitespace) {
>  			/*
> @@ -608,6 +726,7 @@ static int batch_objects(struct batch_options *opt)
>  		batch_one_object(input.buf, &output, opt, &data);
>  	}
>  
> + cleanup:
>  	strbuf_release(&input);
>  	strbuf_release(&output);
>  	warn_on_object_refname_ambiguity = save_warning;
> @@ -636,6 +755,7 @@ static int batch_option_callback(const struct option *opt,
>  
>  	bo->enabled = 1;
>  	bo->print_contents = !strcmp(opt->long_name, "batch");
> +	bo->command = !strcmp(opt->long_name, "batch-command");
And this part needs fixing.  The original used to say
	we supoprt "batch" and something else (it turns out that
	"batch-check" is that something else, but the above code is
	so sloppy that it does not even tell readers that), and
	the .print_contents member is how you can tell them apart.

This patch is making it worse by introducing another member that can be independently set or unset, pretending that the four combinations all can make sense, but that is not the case, right?

So, perhaps a good first step would be to lose .print_contents member and add .batch_command member that is used to more explicitly name one of the three possibilities?

Previous: Jonathan TanNext: Phillip Wood
Message 23 of 97 in “Add cat-file --batch-command flag”
  1. 0/2 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 3, 2022
  2. 1/2 cat-file.c: rename cmdmode to modeJohn Cai via GitGitGadget, Feb 3, 2022
  3. Junio C HamanoFeb 3, 2022
  4. Ævar Arnfjörð BjarmasonFeb 4, 2022
  5. 2/2 catfile.c: add --batch-command modeJohn Cai via GitGitGadget, Feb 3, 2022
  6. Junio C HamanoFeb 3, 2022
  7. John CaiFeb 4, 2022
  8. Phillip WoodFeb 4, 2022
  9. Eric SunshineFeb 4, 2022
  10. John CaiFeb 4, 2022
  11. Eric SunshineFeb 5, 2022
  12. Ævar Arnfjörð BjarmasonFeb 4, 2022
  13. Phillip WoodFeb 4, 2022
  14. 0/2 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 7, 2022
  15. 1/2 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 7, 2022
  16. Junio C HamanoFeb 7, 2022
  17. 2/2 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 7, 2022
  18. Jonathan TanFeb 7, 2022
  19. Phillip WoodFeb 8, 2022
  20. Jonathan TanFeb 8, 2022
  21. Junio C HamanoFeb 8, 2022
  22. Jonathan TanFeb 9, 2022
  23. Junio C HamanoFeb 8, 2022
  24. Phillip WoodFeb 8, 2022
  25. 0/3 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 8, 2022
  26. 1/3 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 8, 2022
  27. 3/3 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 8, 2022
  28. Junio C HamanoFeb 8, 2022
  29. 2/3 cat-file: introduce batch_command enum to replace print_contentsJohn Cai via GitGitGadget, Feb 8, 2022
  30. Junio C HamanoFeb 8, 2022
  31. Junio C HamanoFeb 9, 2022
  32. John CaiFeb 9, 2022
  33. John CaiFeb 9, 2022
  34. 0/3 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 10, 2022
  35. 1/3 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 10, 2022
  36. 2/3 cat-file: introduce batch_mode enum to replace print_contentsJohn Cai via GitGitGadget, Feb 10, 2022
  37. Christian CouderFeb 10, 2022
  38. 3/3 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 10, 2022
  39. Phillip WoodFeb 10, 2022
  40. Junio C HamanoFeb 10, 2022
  41. John CaiFeb 11, 2022
  42. Junio C HamanoFeb 11, 2022
  43. John CaiFeb 11, 2022
  44. John CaiFeb 10, 2022
  45. Eric SunshineFeb 10, 2022
  46. Junio C HamanoFeb 10, 2022
  47. 0/3 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 11, 2022
  48. 1/3 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 11, 2022
  49. 2/3 cat-file: introduce batch_mode enum to replace print_contentsJohn Cai via GitGitGadget, Feb 11, 2022
  50. 3/3 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 11, 2022
  51. Phillip WoodFeb 14, 2022
  52. John CaiFeb 14, 2022
  53. 0/4 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 14, 2022
  54. 1/4 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 14, 2022
  55. 2/4 cat-file: introduce batch_mode enum to replace print_contentsJohn Cai via GitGitGadget, Feb 14, 2022
  56. 3/4 cat-file: add remove_timestamp helperJohn Cai via GitGitGadget, Feb 14, 2022
  57. 4/4 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 14, 2022
  58. Eric SunshineFeb 15, 2022
  59. John CaiFeb 15, 2022
  60. Eric SunshineFeb 15, 2022
  61. 0/4 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 16, 2022
  62. 1/4 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 16, 2022
  63. 2/4 cat-file: introduce batch_mode enum to replace print_contentsJohn Cai via GitGitGadget, Feb 16, 2022
  64. 3/4 cat-file: add remove_timestamp helperJohn Cai via GitGitGadget, Feb 16, 2022
  65. 4/4 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 16, 2022
  66. Junio C HamanoFeb 16, 2022
  67. John CaiFeb 16, 2022
  68. Junio C HamanoFeb 16, 2022
  69. Eric SunshineFeb 16, 2022
  70. Eric SunshineFeb 16, 2022
  71. 0/4 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 16, 2022
  72. 2/4 cat-file: introduce batch_mode enum to replace print_contentsJohn Cai via GitGitGadget, Feb 16, 2022
  73. 1/4 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 16, 2022
  74. 3/4 cat-file: add remove_timestamp helperJohn Cai via GitGitGadget, Feb 16, 2022
  75. 4/4 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 16, 2022
  76. Junio C HamanoFeb 16, 2022
  77. Eric SunshineFeb 16, 2022
  78. John CaiFeb 16, 2022
  79. 0/4 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 16, 2022
  80. 1/4 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 16, 2022
  81. 2/4 cat-file: introduce batch_mode enum to replace print_contentsJohn Cai via GitGitGadget, Feb 16, 2022
  82. 3/4 cat-file: add remove_timestamp helperJohn Cai via GitGitGadget, Feb 16, 2022
  83. 4/4 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 16, 2022
  84. Phillip WoodFeb 18, 2022
  85. John CaiFeb 18, 2022
  86. Junio C HamanoFeb 18, 2022
  87. Junio C HamanoFeb 18, 2022
  88. 0/4 Add cat-file --batch-command flagJohn Cai via GitGitGadget, Feb 18, 2022
  89. 1/4 cat-file: rename cmdmode to transform_modeJohn Cai via GitGitGadget, Feb 18, 2022
  90. 2/4 cat-file: introduce batch_mode enum to replace print_contentsJohn Cai via GitGitGadget, Feb 18, 2022
  91. 3/4 cat-file: add remove_timestamp helperJohn Cai via GitGitGadget, Feb 18, 2022
  92. Ævar Arnfjörð BjarmasonFeb 19, 2022
  93. John CaiFeb 22, 2022
  94. 4/4 cat-file: add --batch-command modeJohn Cai via GitGitGadget, Feb 18, 2022
  95. Ævar Arnfjörð BjarmasonFeb 19, 2022
  96. Junio C HamanoFeb 18, 2022
  97. Phillip WoodFeb 22, 2022

Read the whole thread, see it on lore, or plain text.

$ cat FOOTERMessages come from the public archive at lore.kernel.org/git, fetched every hour. The front page is chosen and written each morning by an AI editor and can be wrong; the threads themselves are the record. About and API. For agents: an MCP server at https://gitlist.dev/mcp, and any thread, story or person page as Markdown by adding .md to its URL (or sending Accept: text/markdown). Details in /llms.txt.