From: Junio C Hamano Date: Mon, 07 Feb 2022 23:58:27 GMT Subject: Re: [PATCH v2 1/2] cat-file: rename cmdmode to transform_mode Message-ID: In-Reply-To: <2d9a0b06ce5ab62095ae9a91d8d56441e9bb8c54.1644251611.git.gitgitgadget@gmail.com> "John Cai via GitGitGadget" writes: > From: John Cai > > When introducing a new flag --batch-command, we will add a flag on the > batch_options struct that indicates whether or not an interactive > command mode will be used that reads commands and arguments off of > stdin. > > An intuitive name for this flag would be "command", which can get > confusing with the already existing cmdmode. Is "command" truly an intuitive name for "were we given '--batch-command' option?" bit? I dunno. But I agree that "transform_mode" is much better name than "cmdmode" for what this member is about.