Re: [GSoC][PATCH 2/2] t4131: use helper function to replace test -f <path>
- From
Junio C Hamano <gitster@pobox.com>
- Date
- Mar 19, 2020, 21:58 UTC
- Message-ID
- <xmqq1rpodn25.fsf@gitster.c.googlers.com>
- In-Reply-To
- <20200319164234.4441-1-shouryashukla.oo@gmail.com>
Shourya Shukla <shouryashukla.oo@gmail.com> writes:
Show 11 quoted lines
> Hello Harshit, > >> Replace 'test -f' with the helper function 'test_path_is_file' as the helper function improves the code readability and also gives better error messages. > > Again the same thing, you may follow what I stated before regarding commit messages. > > The commit title can be of the form: > > t4131: use helpers to replace test -f <path> > > <<commit description>>
I think Harshit is writing the title of the commit in the right place. Format-wise, the only thing that is wrong is that each paragraph is too long without line wrapping.
What is wrong in these two e-mail thread is that you are not reading the log message correctly. When made into a piece of e-mail, the title goes to the "Subject:" field in the header and there is no need to repeat it in the body of the e-mail.