Re: [PATCH 08/15] scalar: implement the `clone` subcommand
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Sep 3, 2021, 15:21 UTC
- Message-ID
- <nycvar.QRO.7.76.6.2109031720420.55@tvgsbejvaqbjf.bet>
- In-Reply-To
- <CAPig+cSy=mps-b3HWZSC7WcMaYV_H71BVRK5b0cSy2fA0ogJ7w@mail.gmail.com>
Hi Eric,
On Tue, 31 Aug 2021, Eric Sunshine wrote:
Show 14 quoted lines
> On Tue, Aug 31, 2021 at 8:04 AM Ævar Arnfjörð Bjarmason > <avarab@gmail.com> wrote: > > On Mon, Aug 30 2021, Johannes Schindelin via GitGitGadget wrote: > > > Note: We intentionally use a slightly wasteful `set_config()` function > > > (which does not reuse a single `strbuf`, for example, though performance > > > _really_ does not matter here) for convenience and readability. > > > > FWIW I think the commit message could do without this, that part of the > > code is obviously not performance sensitive at all. But maybe an > > explicit note helps anyway... > > FWIW, I also found this distracting; it takes the reader's attention > away from more important aspects of the patch. (But it alone is not > worth a re-roll; it was just a minor hiccup.)
Since I reworked the remote default branch parsing anyway, I removed this paragraph from the commit message.
Ciao, Dscho