Re: [PATCH v3 00/15] [RFC] Upstreaming the Scalar command
- From
Ævar Arnfjörð Bjarmason <avarab@gmail.com>
- Date
- Sep 9, 2021, 10:14 UTC
- Message-ID
- <87r1dydp4m.fsf@evledraar.gmail.com>
- In-Reply-To
- <pull.1005.v3.git.1631129086.gitgitgadget@gmail.com>
On Wed, Sep 08 2021, Johannes Schindelin via GitGitGadget wrote:
Show 13 quoted lines
> Changes since v2: > > * Adjusted the description of the list command in the manual page , as > suggested by Bagas. > * Addressed two style nits in cmd_run(). > * The documentation of git reconfigure -a was improved. > > Changes since v1: > > * A couple typos were fixed > * The code parsing the output of ls-remote was made more readable > * The indentation used in scalar.txt now consistently uses tabs > * We no longer hard-code core.bare = false when registering with Scalar
In the summary I had on v1->v2 points 1-3 are for v2->v3, respectively, outstanding, addressed, outstanding:
https://lore.kernel.org/git/877dfupl7o.fsf@evledraar.gmail.com/
In addition the discussion ending here: https://lore.kernel.org/git/nycvar.QRO.7.76.6.2109082112270.55@tvgsbejvaqbjf.bet/
For that point: I think it's fair enough not to properly handle the cleanup case in "scalar clone", but perhaps add a note in the commit message that unlike "git clone" this is known not to clean after itself properly on ctrl+c?