Re: [PATCH 08/15] scalar: implement the `clone` subcommand
- From
Eric Sunshine <sunshine@sunshineco.com>
- Date
- Aug 31, 2021, 16:47 UTC
- Message-ID
- <CAPig+cSy=mps-b3HWZSC7WcMaYV_H71BVRK5b0cSy2fA0ogJ7w@mail.gmail.com>
- In-Reply-To
- <87a6kyxbo1.fsf@evledraar.gmail.com>
On Tue, Aug 31, 2021 at 8:04 AM Ævar Arnfjörð Bjarmason <avarab@gmail.com> wrote:
Show 8 quoted lines
> On Mon, Aug 30 2021, Johannes Schindelin via GitGitGadget wrote: > > Note: We intentionally use a slightly wasteful `set_config()` function > > (which does not reuse a single `strbuf`, for example, though performance > > _really_ does not matter here) for convenience and readability. > > FWIW I think the commit message could do without this, that part of the > code is obviously not performance sensitive at all. But maybe an > explicit note helps anyway...
FWIW, I also found this distracting; it takes the reader's attention away from more important aspects of the patch. (But it alone is not worth a re-roll; it was just a minor hiccup.)