Re: [PATCH v2 00/15] Assorted fixes for `git config` (including the "empty sections" bug)
- From
Johannes Schindelin <johannes.schindelin@gmx.de>
- Date
- Apr 3, 2018, 16:30 UTC
- Message-ID
- <nycvar.QRO.7.76.6.1804031829400.5026@qfpub.tvgsbejvaqbjf.bet>
- In-Reply-To
- <cover.1522772789.git.johannes.schindelin@gmx.de>
Hi team,
On Tue, 3 Apr 2018, Johannes Schindelin wrote:
Show 16 quoted lines
> Johannes Schindelin (15): > git_config_set: fix off-by-two > t1300: rename it to reflect that `repo-config` was deprecated > t1300: demonstrate that --replace-all can "invent" newlines > config --replace-all: avoid extra line breaks > t1300: avoid relying on a bug > t1300: remove unreasonable expectation from TODO > t1300: `--unset-all` can leave an empty section behind (bug) > config: introduce an optional event stream while parsing > config: avoid using the global variable `store` > config_set_store: rename some fields for consistency > git_config_set: do not use a state machine > git_config_set: make use of the config parser's event stream > git config --unset: remove empty sections (in the common case) > git_config_set: reuse empty sections > TODOs
Please note that the `TODOs` commit is a left-over of my internal book-keeping, and its diff is actually empty. Hence `format-patch` does not even generate a mail for it, so there is no [PATCH v2 15/15].
Thanks, Dscho