Re: [PATCH 2/2] daemon: report permission denied error to clients
Clemens Buchacher <drizzd@aon.at> wrote:
Show 6 quoted lines
>
> I guess if permission is denied for access over git://, then nobody
> can use the repository. So it's clearly a server side issue.
>
> This change probably makes more sense for local access and over
> ssh. I already have a similar patch brewing for that.
As far as security is concerned, we have to treat ssh the same as git://, unless the user has permission to execute arbitrary commands and not just git-upload-pack. But I can think of no way to figure that out on the server side.