Re: [PATCH] daemon: return "access denied" if a service is not allowed
- From
Jeff King <peff@peff.net>
- Date
- Oct 14, 2011, 13:10 UTC
- Message-ID
- <20111014131041.GC7808@sigill.intra.peff.net>
- In-Reply-To
- <7vvcrs181e.fsf@alter.siamese.dyndns.org>
On Thu, Oct 13, 2011 at 10:01:01PM -0700, Junio C Hamano wrote:
Show 12 quoted lines
> Jeff King <peff@peff.net> writes: > > > So if we want to do anything, I would think it would be a hook. Except > > that we may or may not have a repo, so it would not be a hook in > > $GIT_DIR/hooks, but rather some script to be run passed on the command > > line, like: > > > > git daemon --informative-errors=/path/to/hook > > I don't think it is necessarily good to have such a variation across > hosting sites. Your "something like this" patch looked like it was giving > a reasonable level of detail, IMO.
Yeah. With arbitrary messages, the client has no way of programatically deciphering which message is which, so localization becomes impossible. HTTP solved this by having a response code _and_ still allowing content for custom pages. That kind of works, though most of the time I find things like custom 404 pages to just be junk.
Let's start with my original patch (which I'll clean and repost). And if somebody really wants to push towards customized messages, that is easy enough to do on top later.
-Peff