Re: [PATCH 04/28] packed_ref_store: move `packed_refs_lock` member here
- From
Michael Haggerty <mhagger@alum.mit.edu>
- Date
- Jun 16, 2017, 06:43 UTC
- Message-ID
- <bf1fcee3-2f2f-b153-5774-dee5b2a2790d@alum.mit.edu>
- In-Reply-To
- <CAGZ79ka3u_otP6M+oRBb4dQdMQx6kFHaXihLsBpM23gqzwqOGw@mail.gmail.com>
On 06/16/2017 07:39 AM, Stefan Beller wrote:
Show 17 quoted lines
> On Thu, Jun 15, 2017 at 7:47 AM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
>> [...]
>> @@ -125,7 +125,7 @@ static void clear_packed_ref_cache(struct files_ref_store *refs)
>> if (refs->packed_ref_store->cache) {
>> struct packed_ref_cache *packed_refs = refs->packed_ref_store->cache;
>>
>> - if (is_lock_file_locked(&refs->packed_refs_lock))
>> + if (is_lock_file_locked(&refs->packed_ref_store->lock))
>
> I sort of stumble over the name due to singular/plural/genetive issues:
> The store contains multiple of "packed ref"(s) or the store is specialized in
> packed ref(s). On the other hand in English you seem to reference the
> specialisation of a store in singular: It's a "gun store" (not "guns store")
> or "furniture store" or "fresh fish store" (though that could be
> plural as well).
>
> It just sounded odd to me. (though think of it as a minor nit)I chose that name because it is a `ref_store`, with `packed_` being a short prefix that tells what kind of `ref_store`.
The next question is, why `ref_store` as opposed to `refs_store`? To me it sounds more natural in English for the reasons that you mentioned.
Michael