Re: [PATCH 04/28] packed_ref_store: move `packed_refs_lock` member here
- From
Stefan Beller <sbeller@google.com>
- Date
- Jun 16, 2017, 05:39 UTC
- Message-ID
- <CAGZ79ka3u_otP6M+oRBb4dQdMQx6kFHaXihLsBpM23gqzwqOGw@mail.gmail.com>
- In-Reply-To
- <eea8f3d25e9d3d3a0b63604338f10cfa658bbb43.1497534157.git.mhagger@alum.mit.edu>
On Thu, Jun 15, 2017 at 7:47 AM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
Show 45 quoted lines
> Move the `packed_refs_lock` member from `files_ref_store` to
> `packed_ref_store`, and rename it to `lock` since it's now more
> obvious what it is locking.
>
> Signed-off-by: Michael Haggerty <mhagger@alum.mit.edu>
> ---
> refs/files-backend.c | 31 ++++++++++++++++---------------
> 1 file changed, 16 insertions(+), 15 deletions(-)
>
> diff --git a/refs/files-backend.c b/refs/files-backend.c
> index c4b8e2f63b..de8293493f 100644
> --- a/refs/files-backend.c
> +++ b/refs/files-backend.c
> @@ -62,6 +62,12 @@ struct packed_ref_store {
> * it might still be current; otherwise, NULL.
> */
> struct packed_ref_cache *cache;
> +
> + /*
> + * Lock used for the "packed-refs" file. Note that this (and
> + * thus the enclosing `packed_ref_store`) must not be freed.
> + */
> + struct lock_file lock;
> };
>
> static struct packed_ref_store *packed_ref_store_create(
> @@ -87,12 +93,6 @@ struct files_ref_store {
>
> struct ref_cache *loose;
>
> - /*
> - * Lock used for the "packed-refs" file. Note that this (and
> - * thus the enclosing `files_ref_store`) must not be freed.
> - */
> - struct lock_file packed_refs_lock;
> -
> struct packed_ref_store *packed_ref_store;
> };
>
> @@ -125,7 +125,7 @@ static void clear_packed_ref_cache(struct files_ref_store *refs)
> if (refs->packed_ref_store->cache) {
> struct packed_ref_cache *packed_refs = refs->packed_ref_store->cache;
>
> - if (is_lock_file_locked(&refs->packed_refs_lock))
> + if (is_lock_file_locked(&refs->packed_ref_store->lock))I sort of stumble over the name due to singular/plural/genetive issues: The store contains multiple of "packed ref"(s) or the store is specialized in packed ref(s). On the other hand in English you seem to reference the specialisation of a store in singular: It's a "gun store" (not "guns store") or "furniture store" or "fresh fish store" (though that could be plural as well).
It just sounded odd to me. (though think of it as a minor nit)