Re: [PATCH 15/28] packed_peel_ref(): new function, extracted from `files_peel_ref()`
- From
Stefan Beller <sbeller@google.com>
- Date
- Jun 16, 2017, 15:47 UTC
- Message-ID
- <CAGZ79kb=eq88VR5nQggnLQJX-gTZ37uhm3PhuhC4oX8dw8vG5w@mail.gmail.com>
- In-Reply-To
- <db616bc6-4d31-6f7c-4862-9161f4bb36ce@alum.mit.edu>
On Thu, Jun 15, 2017 at 11:46 PM, Michael Haggerty <mhagger@alum.mit.edu> wrote:
Show 18 quoted lines
> On 06/16/2017 07:42 AM, Stefan Beller wrote: >> On Thu, Jun 15, 2017 at 7:47 AM, Michael Haggerty <mhagger@alum.mit.edu> wrote: >>> This will later become a method of `packed_ref_store`. >> >> Also while touching it, maybe rename sha1 to object_hash >> (not saying object_id as that would be confusing with the actual >> oid struct), maybe? > > Hmmm, my impression was that most of the `unsigned char *` hashes are > still called sha1, and they are renamed to `oid` at the moment that they > are converted to `struct object_id *`. I only see two instances of the > string "object_hash" in the code: > > $ git grep object_hash > object.c:static void grow_object_hash(void) > object.c: grow_object_hash(); > > Michael
Yeah maybe we can just defer it to the proper conversion series. I just jumped the gun here.